The issue has been resolved, and system performance has returned to normal. Thank you for your patience while we worked on the resolution.
Posted Sep 05, 2025 - 09:49 PDT
Update
The fix has been successfully applied, and system performance has returned to normal levels. We are monitoring closely over the next few hours to ensure everything remains stable. Thank you for your patience and understanding.
Posted Sep 05, 2025 - 05:14 PDT
Update
We are still observing performance issues. The Development team is preparing and will be applying the fix within the next few hours. We remain in active monitoring and will provide a final update once performance is fully stabilized.
Posted Sep 04, 2025 - 22:36 PDT
Monitoring
We have implemented a fix for the slowness issue and are actively monitoring the system to ensure performance remains stable. We will provide a final update once we are confident that the system is functioning as expected.
Posted Sep 04, 2025 - 11:27 PDT
Update
Our team is continuing to investigate the slowness. We are actively testing potential solutions and will share the next update as soon as we have more details. Thank you for your patience.
Posted Sep 04, 2025 - 10:07 PDT
Investigating
The Core application is currently experiencing slowness in Project List page impacting some customers. The team is actively investigating and working on a resolution.
Posted Sep 04, 2025 - 09:15 PDT
This incident affected: CORE (CORE API Services (US)).