Cloudflare Outage

Incident Report for BQE CORE

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 08:27 PST

Update

The issue has been fully resolved, and all CORE functions are now operating normally. Everything is working as expected. We will continue to monitor the system closely to ensure stability. Thank you for your patience and understanding during this time.
Posted Nov 18, 2025 - 08:25 PST

Monitoring

The CORE application is fully accessible and Cloudflare has stabilized. No further impact is expected at this time. We will continue to monitor, but all services are operating normally.
Posted Nov 18, 2025 - 05:19 PST

Update

We are continuing to investigate this issue.
Posted Nov 18, 2025 - 04:44 PST

Investigating

We are currently affected by a widespread Cloudflare outage that is impacting multiple services worldwide. As a result, some users may experience:
• Slow loading times for BQECORE
• Intermittent “502/504” errors or temporary unavailability
Our engineers are looking into the issues and we are also actively monitoring Cloudflare’s live updates. We will send a follow-up as soon as services are fully restored.

Cloudflare incident link (for reference): https://www.cloudflarestatus.com/

Thank you for your patience.
Posted Nov 18, 2025 - 04:28 PST
This incident affected: BQECORE - US, CAN & UK (Login and SSO (Single Sign-On) Services, CORE Front-End UI) and BQECORE - AUS & UAE (Login and SSO (Single Sign-On) Services, CORE Front-End UI).