Slowness in Report Generation for few customers ( US Region only )

Incident Report for BQE CORE

Resolved

The issue related to "inability to preview reports/invoices" has been resolved. We apologize for any disruption this may have caused and appreciate your patience during the resolution process. Please be assured that we are taking proactive steps to prevent similar issues in the future.

Thank you for your continued support. If you are still experiencing any issues, please contact BQE CORE Support at support@bqe.com or call 310-602-4030.
Posted Apr 01, 2025 - 17:31 PDT

Monitoring

We are currently monitoring the system to ensure stability and full functionality. Early signs indicate that services are operating normally, but we are closely observing performance to confirm that the issue is fully resolved.

It is recommended that you log out and log back in to BQE CORE. We will provide a final update once monitoring is complete. Thank you for your patience throughout this process.
Posted Apr 01, 2025 - 12:07 PDT

Identified

Our team has made significant progress in implementing the fix. We are committed to ensuring the issue is fully resolved and are conducting additional tests to confirm stability.

Thank you for your continued patience and understanding. We will keep you updated with any further developments.
Posted Apr 01, 2025 - 11:28 PDT

Update

We can still see slowness in reports and invoices for few customers. Our Engineering team is actively working to resolve these issues as quickly as possible. We appreciate your patience and understanding and will provide updates as we make progress.
Posted Apr 01, 2025 - 10:44 PDT

Monitoring

The fix for the issue has been implemented, and we are currently monitoring the system to ensure stability and full functionality. Early signs indicate that services are operating normally, but we are closely observing performance to confirm that the issue is fully resolved.

It is recommended that you log out and log back in to BQE CORE. We will provide a final update once monitoring is complete. Thank you for your patience throughout this process.
Posted Apr 01, 2025 - 09:56 PDT

Identified

We have identified the root cause of the issue. Our team is actively implementing a fix. Thank you for your patience and understanding as we work to restore full functionality.
Posted Apr 01, 2025 - 09:43 PDT

Investigating

Some of our users [USA region] have reported that they are unable to preview to reports/invoices.
Our Engineering team is actively investigating and working to resolve these issues as quickly as possible. We appreciate your patience and understanding and will provide updates as we make progress.

To stay informed, please subscribe to this page for real-time updates.
For any questions, please contact BQE CORE Support at support@bqe.com or call 310-602-4030.
Posted Apr 01, 2025 - 09:42 PDT
This incident affected: CORE (CORE Reporting Services (US)).