Investigation
Incident Report for BQE CORE
Resolved
The issue with the inability to preview reports/invoices has been resolved. We apologize for any disruption this might have caused you. Rest assured that we are doing everything possible to prevent such issues from occurring in the future. Thank you for your patience and continued support. If you are still experiencing any problems, please reach out to CORE Support via email at support@bqe.com or via phone at 310-602-4030.
Posted Sep 19, 2022 - 12:17 PDT
Update
We are continuing to investigate this issue.
Posted Sep 19, 2022 - 12:16 PDT
Investigating
Some of our users have reported that they are experiencing inability to preview reports/invoices. Our Engineering teams are working diligently to identify and fix these issues as quickly as possible. Please subscribe to this page to receive the latest updates.
Posted Sep 19, 2022 - 12:11 PDT